Speedos gone nuts

Talk about anything 300ZX
Post Reply
Message
Author
pistolpedro
Stage 2 - ECU upgrade
Posts: 37
Joined: Fri Jun 24, 2011 2:47 pm
Location: Invercargill
Contact:

Speedos gone nuts

#1 Post by pistolpedro » Wed Dec 02, 2015 10:32 am

Been reading lots of threads from here and others about when the speedo goes crazy, either being the sender on the trans (which iv checked visually and seems fine, connections cleaned etc but not removed as i couldnt get car far enough off the ground) or the gauge which i really hope not... Symptoms are speedo not working at all or jumping around or stuck past the 190km mark, odometer working intermittently tho hardly at all,but cruise control and power steering working fine... Anybody have an idea which it could be before i have to start buying parts and pulling stuff to bits lol

Cheers and seasons greetings :?

User avatar
lil-vulky
Stage 11 - sport turbo's
Posts: 1513
Joined: Fri Mar 06, 2009 11:21 am
Location: Nelson
Contact:

#2 Post by lil-vulky » Wed Dec 02, 2015 3:57 pm

id say you need a new speedo cluster, there cheap to get one second hand though for a stock speedo.

this here wont fix anything but my speedo worked fine but the odo meter sometimes wouldn't work because the motor was abit dirty so i ended up cleaning it as this link says. but that only works if the speedo is actually working fine but the odo isnt.

http://www.angelfire.com/geek/vg30dett/ ... luster.htm

since yours isnt reading proper speed id say just replace the cluster, or pull the cluster out and clean all the connections behind it. you should be able to get a good cluster for $50.

pistolpedro
Stage 2 - ECU upgrade
Posts: 37
Joined: Fri Jun 24, 2011 2:47 pm
Location: Invercargill
Contact:

#3 Post by pistolpedro » Thu Dec 03, 2015 11:45 am

Cheers, thats a really good how to to get the cluster out, il try cleaning it first and if that doesnt work i will have to start looking for another N/A cluster

User avatar
lil-vulky
Stage 11 - sport turbo's
Posts: 1513
Joined: Fri Mar 06, 2009 11:21 am
Location: Nelson
Contact:

#4 Post by lil-vulky » Thu Dec 03, 2015 4:33 pm

iv got a good cluster here in my spare 300zx i could probably sell if you can't find one, although id prefer to keep it as a spare for me but if you have trouble finding one ill sell it to you, just let me know.

I cleaned my old one maybe 3 times and got another 12-18months before i ended up replacing it.

I hope my current speedo doesn't have that problem though, since its a 300km nismo one

pistolpedro
Stage 2 - ECU upgrade
Posts: 37
Joined: Fri Jun 24, 2011 2:47 pm
Location: Invercargill
Contact:

#5 Post by pistolpedro » Fri Dec 04, 2015 10:26 am

Got cluster out, cleaning everything up and will hopefully get back in this avo, fingers crossed.. if it doesn't work may have to take you up on the cluster but will a twin turbo cluster still work in my non turbo dash?

pistolpedro
Stage 2 - ECU upgrade
Posts: 37
Joined: Fri Jun 24, 2011 2:47 pm
Location: Invercargill
Contact:

#6 Post by pistolpedro » Fri Dec 04, 2015 12:14 pm

Well bad news it didnt work and i think i just buggered the backing for the pods on either side, though they were already half stuffed.. Someones had them off before and over-tightened them back up breaking the plastic screw slots where the buttons secure on :( Would you have spare ones of those.....?

Got feelers on Trademe the other day but responses say well over 100 for the clusters plus shipping and which are in unknown condition..

User avatar
MikeC
Elite Z owner, king of modification
Posts: 1168
Joined: Tue Aug 05, 2003 6:50 pm
Location: Tauranga
Contact:

#7 Post by MikeC » Fri Dec 04, 2015 6:00 pm

I hope my current speedo doesn't have that problem though, since its a 300km nismo one
sweet where did you get that?

User avatar
lil-vulky
Stage 11 - sport turbo's
Posts: 1513
Joined: Fri Mar 06, 2009 11:21 am
Location: Nelson
Contact:

#8 Post by lil-vulky » Sat Dec 05, 2015 9:41 am

MikeC wrote:
I hope my current speedo doesn't have that problem though, since its a 300km nismo one
sweet where did you get that?
Came with the car from japan when i imported it. Although its the 2nd 300km nismo speedo iv had, my old 300zx had one as well.

My spare cluster is from a NA so it'l work fine, but TT clusters work in a NA fine anyway

And yes i have a couple spare pods as well ill hunt them out

pistolpedro
Stage 2 - ECU upgrade
Posts: 37
Joined: Fri Jun 24, 2011 2:47 pm
Location: Invercargill
Contact:

#9 Post by pistolpedro » Sat Dec 05, 2015 11:53 am

Thanks mate, big time! Message me how much you want etc. and we can sort out the details :D Cheers!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest